Warning: count(): Parameter must be an array or an object that implements Counta

Inicio Foros Data Table Plugin Warning: count(): Parameter must be an array or an object that implements Counta

Este debate contiene 9 respuestas, tiene 3 mensajes y lo actualizó Alex_support Alex_support hace 1 año, 6 meses.

Viendo 10 publicaciones - del 1 al 10 (de un total de 10)
  • Autor
    Publicaciones
  • #16442

    edu
    Participante

    I have this error at update today to version 1.7.1. I dont remember my previous version, but it work great.

    I get this error on my testing site:
    Warning: count(): Parameter must be an array or an object that implements Countable in /home/user/mysite.com/wp-content/plugins/data-tables-generator-by-supsystic/vendor/Twig/Extension/Core.php on line 1275

    #16447
    mila_support
    mila_support
    Jefe de claves

    Hi @edu

    Thank you for contacting us about our Data Tables Plugin question.

    Please clarify, do you have other plugins by Supsystic? What are they?
    If yes, make sure you have updated them too.

    In the case you have other our plugins and they are already updated but the issue still appears – clean cache in your cache plugin, cache and cookies in your browser and check the issue one more time.

    #16448
    mila_support
    mila_support
    Jefe de claves

    After these operations are maid and the issue still persists,

    most likely there is a conflict with your other plugin or your theme. We hope you understand that we can’t test our products with all other plugins and themes that are available on the market, and we can’t control the other developers. Therefore bad code of other plugins or templates can provoke a lot of problems.
    Please try to deactivate all your plugins one by one and check the issue. Thus you will find out which plugin causes the error. If it won’t help, try to switch temporarily to a standard WordPress theme.

    Then, let us know about the result. This will help our developers to solve your problem faster.

    #16457

    edu
    Participante

    Hello;

    On development website, we dont have any cache.

    We use:

    Data Tables Generator by Supsystic Version 1.7.1 and Select Data Tables Generator PRO Version 1.4.0

    Steps:

    1- Change the WP Theme to “Twenty SeventeenVersion: v1.4” (The problem persist)

    2- Desactive “Select Data Tables Generator PRO Version 1.4.0″ (The problem persist)

    3- Deactivate all plugin except “Select Data Tables Generator” (The problem persist)

    System:

    PHP: PHP 7.0.27-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Jan 5 2018 14:12:46) ( NTS )
    Copyright (c) 1997-2017 The PHP Group
    Zend Engine v3.0.0, Copyright (c) 1998-2017 Zend Technologies
    with Zend OPcache v7.0.27-1+ubuntu16.04.1+deb.sury.org+1, Copyright (c) 1999-2017, by Zend Technologies

    WordPress: version 4.2.9

    #16468
    mila_support
    mila_support
    Jefe de claves

    Hi @edu

    Also please check the WordPress version one more time and let us know.

    #16469

    edu
    Participante

    Hi Support:

    We using WordPress Version 4.9.2 and PHP Version 7.0.27

    Our previous version of Data Table Plugin was “Version 1.6.9”, We found it

    #16470

    edu
    Participante

    I’m test it on two site and when I update to “Data Tables Generator by Supsystic Version 1.7.1” came the error.

    Please I need your help.
    Thanks in advances.
    Up3 Group

    #16471

    edu
    Participante

    Hello Support;

    Try to test install “Data Tables Generator by Supsystic Version 1.7.1” on PHP 7.2.

    Thanks.

    #16472

    edu
    Participante

    I found the problem.

    The problem is in PHP Version 7.2

    #17665
    Alex_support
    Alex_support
    Moderador

    Hi, @edu.
    Can I ask you – do you still have problems with Data Tables installation of PHP version 7.2?

Viendo 10 publicaciones - del 1 al 10 (de un total de 10)

Debes estar registrado para responder a este debate.

Obtenha os pacotes de plugins hoje e economize mais de 80%