Contact Form with Required Lists Question

Home Forums Contact Form Plugin Contact Form with Required Lists Question

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #14338

    icmit
    Participant

    I have a contact form which contains both a country list and a custom list of contact reasons.
    Both have the required box ticked on both
    The country list has no default
    The custom list has a default of Not selected as there does not appear to be a “no default” option

    The business requirement for the contact form is that the user must select which country they are from and select one of the reasons for contact.

    Unfortuantely I don’t seem able to achieve this. Is there any way to achieve this goal?

    Thanks in advance
    John

    #14415
    mila_support
    mila_support
    Member

    Hi @icmit

    Thank you for contacting us regarding your question!

    We will add ability to make one country be chosen by default in one of the next versions of the plugin. I will inform you about the update.

    Also, if you made any field required, user will be forced to make a choice in it of fill it in.
    Otherwise the Contact Form will not be submitted.

    About custom field. You can make one of it’s option be chosen by default – http://prntscr.com/fk4lcj . For this follow the next instruction:
    1. Open needed Contact Form Settings
    2. Go to Fields Tab
    3. Click “Add New Field” and choose Select List
    4. Set it’s Name, Label and create some Options (In your cause reasons for contact)
    5. One of the options Name insert into “Default value” field
    6. Check Required and Click Ok
    7. Save changes of your Contact Form
    http://prntscr.com/fk4iei

    #14416

    icmit
    Participant

    Sorry I didn’t make myself clear

    The problem I have is that I have a country list with no default value (which is what I want), I don’t choose a country and when I press send the form submits when it shouldn’t
    We don’t want the form to submit until the user chooses a country. The required flag does not seem to work

    #14429
    mila_support
    mila_support
    Member

    Hi @icmit

    We tried to reproduce the issue on our test servers and had no luck with it.
    Please provide the page link on your site with the issue.
    Thus I can see what’s wrong and try to help you.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.
Get plugins bundle today and save over 80%