No Popup on Specific URL

Home Forums PopUp Plugin No Popup on Specific URL

This topic contains 17 replies, has 7 voices, and was last updated by Dante_Support Dante_Support 9 months, 2 weeks ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #7712

    Sam
    Participant

    I want my popup to ONLY appear on a specific URL, not the rest of my site. Furthermore, I want the popup to appear regardless of how the user navigates there (e.g menu click, directly, internal link). As a result, I inserted the URL into the box labeled “Hide/Show Only for URL match.” When I tested on my website, I received the following error message:

    Warning: preg_match(): Unknown modifier ‘/’ in /home/nuwaverl/public_html/kylewiney.com/wp-content/plugins/popup-by-supsystic-pro/add_options/mod.php on line 137

    How do I achieve the result I’m looking for?

    #7715
    mila_support
    mila_support
    Keymaster

    Hello!

    Please send us the screenshot of your settings from the Main tab and the link, on which you want to show the popup. We will help you to set it correctly.

    #7734

    Sam
    Participant
    #7761
    mila_support
    mila_support
    Keymaster

    Hello again!

    If you want to show the popup on a specific page please choose the option Show on next pages/posts on the Main tab (please check http://prntscr.com/af6cc2). There you can specify on what pages/posts to show the popup.
    In the option Show only for URL match you need to use regular expressions and enter there only URL patterns. This option has a bit different functions.
    Please set Show on next pages and write me if you have any problems or questions with it.

    #17788

    haitham
    Participant

    Hi there,

    I tried almost everything to make this work but it’s not, I need need the popup to show up only if the url contains “/english/” what is the expression to do this ?

    #17790
    Alex_support
    Alex_support
    Moderator

    Hello, @haitham
    I can recommend you to configure your popup using “Hide/Show only for Languages” setting: http://prntscr.com/jnwut8 – using this option you can set toi show popup only for users with English version of browser.
    Unfortunately there is no option to set “url contain” condition in whom to show parameters.

    #17807

    haitham
    Participant

    Hi Alex,

    The point is, I’m using WPML for localizing my website, and I need to display different popup with each language the user chooses not based on the browser language, for example if my browser is running on English version and I need to see the website content in another language in this case the i’ll switch the website language through the WPML switcher, I need when switching to another language, I only see that language popup’s based on the configuration I’ve done.

    #17826

    hetman.sumy
    Member

    Hello, @haitham
    You can try our option Hide/Show for URL match: http://prntscr.com/jofo6r – simply put in this field required language code from your url and save settings.
    This way you hide specific popup for some language and show it for all other, or vice versa – show it only for specified language and hide for all other.

    #17829

    haitham
    Participant

    Hi Hetman,

    Unfortunately, when I set this option to HIDE en, the pop is not showing at all even the url doesn’t contains en or it contains en, also when I set SHOW and the page url contains en, it always show the popup even the url doesn’t contains en.

    It seems the condition not working as it should be.

    #17832
    Alex_support
    Alex_support
    Moderator

    Thank you for explanaition. I’ll create a task for our developer to fix this function as soon as possible.

    #17834

    haitham
    Participant

    Hi Alex,

    Is there any ticket number that I can following with ?

    #17840
    Alex_support
    Alex_support
    Moderator

    Hello, @haitham
    You can give me your email address and I’ll add it to this task. This way we don’t forget to notify you, when this issue will be fixed.

    #17843
    Alex_support
    Alex_support
    Moderator

    Follow-up to my previous message.
    Please contact us via internal support and I’ll provide you a PRO version with fix for this option.

    #17845

    haitham
    Participant

    Hi Alex,

    I’ve sent a contact you on the internal support and sent you my email.

    #20944

    haitham
    Participant

    Hi there,

    1- When I updated the plugin to latest version this fix is not working any more, are you sure that you’ve integrated this fix in your source code?

    2- If I need to use two url’s in the url match option as per this Screenshot is this correct? because it’s not working.

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.

Get plugins bundle today and save over 80%