PopUp Delay

Home Forums PopUp Plugin PopUp Delay

Tagged: 

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #22450

    joscudder
    Participant

    Here is a mystery. I have a page with about 25 links to 25 Simple HTML PopUps. I use the [supsystic-show-popup id=100] method for each link. Upon first going to that page and clicking on any of the links there is up to a 15 sec delay before the PopUp appears. Once that Popup has been viewed and closed, clicking on any of the other links, those PopUp appear almost immediately (as they should) with no delay.

    The content contained in the Simple HTML PopUps make no difference, even a blank PopUp will have a 15 sec delay if it is the first one selected. Using a different theme had no effect on that first PopUp either. The page was built with Elementor.

    What could be causing this delay? I use the same PopUp method on another site that uses the same theme and same companion plugins, but that site works perfectly for the first PopUp opening. As far as I can see I have the exact same settings for both sites. It is a mystery.

    Here is a link the troublesome page: https://moultonboroumc.org/sermons/

    John

    #22451

    joscudder
    Participant

    After some further experimentation I have come to the conclusion that the delay is related to the large number of links to PopUps on the page. I created a second page with only 6 links to PopUPs and each PopUp, including the first one hit upon, came up relatively quickly. In the original page, why would the large number of links to PoPups cause the first PopUp to take so long to appear?

    John

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.
Get plugins bundle today and save over 80%