table header mobile responsive issue portrait/lanscape

Home Forums Data Table Plugin table header mobile responsive issue portrait/lanscape

This topic contains 9 replies, has 3 voices, and was last updated by  hetman.sumy 10 months, 1 week ago.

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #18502

    slcetc
    Participant

    I am using the Data table. Using first row header and footer with horizontal scroll. Six columns. Working well overall. Notice the header does not adjust when I change iphone orientation — must reload page manually. Will be confusing for users as they will likely land on page in portrait and immediately change to landscape for wider view. Appreciate advice. Thanks!

    #18505
    Alex_support
    Alex_support
    Moderator

    Hello, @slcetc

    Please give us a link to a page on your website, where we can see and test that issue with responsive mode of data table.
    This helps us to provide you possible solution faster.

    #18540

    slcetc
    Participant

    Car Seat Comparison

    its really both ways. table header and rows are not responding to iphone 6+ changing orientation. looks good in portrait after initial load. rotate to landscape, header doesnt change but rows expand. reload page, all good. now turn back to portrait, not responsive, header and rows still adjusted for landscape.

    I dont recall this behavior from the beginning of use. I use Elementor but havent upgraded to current troublesome release. Updated to latest WP last week. I also added amazon banner ads to two other pages, not this one. Just fyi. Also Im using /span in one of the cells in each row to create stars.

    thanks!

    #18547
    Alex_support
    Alex_support
    Moderator

    Hello, @slcetc.

    We tried to reproduce your problems on our testing servers and didn’t have any luck. So most likely there is a conflict with your other plugin or your theme. We hope you understand that we can’t test our products with all other plugins and themes that are available on the market, and we can’t control the other developers. Therefore bad code of other plugins or templates can provoke a lot of problems.

    Please try to deactivate all your plugins one by one and check the issue. Thus you will find out which plugin causes the error. If it won’t help, try to switch temporarily to a standard WordPress theme.
    More useful information you can find here: https://supsystic.com/tips-for-solving-issues-faster/

    Afterwards let us know about the result. This will help our developers to solve your problem faster.

    #18550

    slcetc
    Participant

    I am truly disappointed you gave up so quickly. Did you go to my site on an iphone and see the results that I described? That has nothing to do with your testing servers. I use the Astra theme with the Elementor Pro page builder, along with a google header code inserter and a thumbnail editor, on the latest version of WordPress. I disabled the two minor plugins with no improvement. There is no point in disabling Elementor as it is the foundation of my site. As I mentioned, I dont recall this non-adjusting behavior until after recent WordPress upgrade.

    I chose Supsystic over other table plugins because I felt it provided the best functionality and had the best team behind it.

    I hope you will reconsider your “We hope you understand…” position, and take a deeper look. Perhaps others are having this issue too.

    Thank you.
    Steve

    #18568

    slcetc
    Participant

    I have not given up in my effort to determine the underlying cause of the mobile responsiveness issue of the Supsystic data table on my Astra/Elementor site. I did notice today that once the iphone 6+ is rotated from one orientation to the other, a touch to the table header will initiate the header and row adjustment to that orientation. Thank you.

    portrait

    Lanscape

    #18569

    slcetc
    Participant

    It appears that I have accidentally solved the issue by checking the Auto Table Width box on the Appearance tab. The box had been unchecked even though I was not using any of the options/settings available when unchecked. I will continue to monitor. Could you please evaluate what I did for reasonability. Does this make sense? Thank you.

    #18574
    Alex_support
    Alex_support
    Moderator

    Hello, Steve.

    Sure we can try to figure out the reason of that issue.
    I contacted our developer about it – he need to view your issue, because we can’t reproduce it – table on testing server recalculate it’s width properly after screen position changes, even with unchecked “Auto Table Width” option.
    So, can you clone your current table with fixed response mode, uncheck it’s automatic width and place it on some private page for further investigation? Then our developer will try find out what is wrong with it.

    #18593

    slcetc
    Participant

    The table on a test site with same format and data from live site. URL is test.yunodo.com/supsystic .

    Please clarify “fixed response mode”. On Features Tab I see a Responsive Mode, but only options are Standard Responsive Mode, Automatic Column Hiding, Horizontal Scroll, and Disable Responsivity. I am using Horizontal Scroll.

    Thank you.

    #18724

    hetman.sumy
    Member

    Hello, Steve.

    Thank you for provided link to a table. Please, contact us via internal support for further investigation of that issue.

Viewing 10 posts - 1 through 10 (of 10 total)

You must be logged in to reply to this topic.

Get plugins bundle today and save over 80%