PHP 7 compatibility

PHP Compatibility

Do Ultimate plugins by Supsysric compatible with PHP 7.1/7.2?

Actually, when developing our plugins, we use a test server with PHP 5.2, 5.3, 5.6, 7.0, 7.1, 7.2, 7.3 with different settings, so there should be no issues.

Supsystic plugins work fine with every version of PHP all the way up to 7.3.

“PHP Compatibility Checker Report says plugin is not compatible”

We are aware that the PHP checker can provide information that is valuable but not necessarily defining as to compatibility.
If you performed a scan using “PHP Compatibility Checker” or any another checker and got warnings, these are just warnings, nothing to worry about here.

Because our plugins have checks built-in that prevent the functions are called wrongly. They will only be called if they are available. The plugin you use to test with does not take into account code made for backwards compatibility.

By the way, if you have a plugin that is up to date but still flagged as incompatible, it might also be a false positive.

Which version is recommended to use?

To the best of our knowledge, all our plugins are compatible with the latest stable releases of PHP and generally, we recommend at least using PHP 7.0.x as secure and stable to use.
This WordPress Statistic the charts showing what sorts of systems people are running WordPress on. As you can see, 45.4 % of developers use 7.0 and up PHP versions. Thus, nearly half of 214.000+ customers use PHP 7.0.x. and Supsystic plugins. Surely, they would have noticed if they had compatibility issues.

So, if you are about to migrate to a current version of PHP, maybe to PHP 7.2, maybe from PHP 5.6, PHP 7.0, you can do it with confidence and be sure our plugins fully compatible.

Categories
Latest Articles
Get plugins bundle today and save over 80%